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Problem
The most common problem with Chaos Cosmos is when the service doesn=E2= =80=99t start due to missing files or insufficient rights to some directori= es created during installation. In such cases, the Cosmos Browser icon= leads to an error page - =E2=80=9CThere is a problem with Chaos Cosmos=E2= =80=9D.
Cause
Such problems are caused by the fact that some of the artifacts coming w= ith Cosmos Browser, such as configuration file, database file or asset stor= age folder, were not installed property or were installed in directories to= which clients have no read/write permissions.
Solution
When such problems occur, the best thing to do is update to the latest C= osmos Browser version, as it resolves most of the installation related prob= lems. To update Cosmos Browser, follow these steps:
Download the latest Cosmos Browser version on this link (requires lo= gin to your Chaos account): https= ://download.chaos.com/?platform=3D47&product=3D62
Install it on your machine
Problem
On some occasions, starting the Chaos Cosmos Browser, leads = to an error page pointing to problems with the connection to the Chaos Cosm= os services.
Cause
Since Chaos Cosmos = is a cloud-based service, it requires connection to the Cosmos service over= the internet. There are two network problems which can interfere with that:
No internet connection
Network firewall or missing proxy configuration
Solution
In the case of No internet connection - fix the network problem and conn= ect to the internet.
In the case of firewall or missing proxy configuration, there are two th= ings to be done (usually, by your IT admins):
Whitelist the domains related to the Chaos Cosmos service:
Problem
On some occasions, write rights to the asset download directory which st= ores assets downloaded in Cosmos are missing. In this case, download attemp= ts result in =E2=80=9CNo access to downloads folder=E2=80=9D error message.=
Cause
There is an asset download folder in which all downloaded Cosmos assets = are saved. The error appears when the write access to this folder is missin= g. By default, the asset download folder is:
On Windows: C:\Users\[User Name]\Documents\Chaos Cosmos
On Mac: ~/Library/ChaosGroup/ChaosCosmos
The location can be changed via UI or in = the configuration file. Here is how.
Solution
When such problems occur, you can either:
Fix the permissions to the asset download directory (your IT admin m=
ight need to assist with that). To see where Cosmos download asset director=
y in Cosmos Browser, go to =E2=80=A6> Settings
Or
Change the existing asset download directory with a new one, to whic= h you have access rights. To do so, go to =E2=80=A6>Settings and follow these instructions.
Problem
An "Oops=E2=80=A6 something went wrong" error message appears.
Cause
The reason for such errors can = vary.
Solution
Try and upgrade to the latest Cosmos Browser version, as des=
cribed in section =E2=80=9CThere is a problem with the Chaos Cosmos error p=
age=E2=80=9D.
If the problem still persists, =
then, contact support. Make sure that you include a screenshot of the error=
to help diagnose the problem.
Problem
Sometimes Cosmos Browser service cannot start because of a problem with = its database.
Cause
Usually downgrade of Cosmos Browser. For example, Cosmos Browser was pre= viously installed and updated from its Update Notification, but then an old= er version was installed, for example with another Chaos product that also = ships Cosmos.
Solution
When such problem occurs, follow these steps:
For Windows:
Stop the Cosmos Browser from the St= art Menu shortcut.
Delete the DB files located at C:\u= ser\username\AppData\Local\Chaos\Cosmos\DB
Start the Cosmos Browser from the S= tart Menu shortcut.
For Mac:
Delete the DB files located at /Use= rs/username/Library/Application Support/Chaos/Cosmos/DB
Open Activity Monitor and search fo= r "cbservice".
Force quit the process - it will au= tomatically start again.
If following the instructions in this page didn=E2=80=99t help and you s= till encounter problems with Chaos Cosmos, then you can contact our support= team on this page.=
Please, make sure you include the cb.log as part of your ticket to help gre=
atly in the investigation process.
To find the folder with the cb.log file, in Cosmos Browser go to =E2=80=A6&=
gt; Settings > About > Open=
.
If you experience performance issu= es like high CPU/Memory usage, you can run the Diagnostics= process (it would take about 30s) and attach the result file in your = ticket.