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There is a problem with Chaos Cosmos

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Problem

The most common problem with Chaos Cosmos is when the service doesn’t start due to missing files or insufficient rights to some directories created during installation. In such cases, the Cosmos Browser

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Common problem causes: 

  • Incompatibility between the Cosmos Browser installed service and the database, which results in an inability to start the Chaos Cosmos Browser Service (in cases of problematic installs resulting in database downgrade) 

  • Incompatibility between the online Chaos Browser UI updates and the Chaos Browser service (in cases of website updates incompatible with local installs)

  • Broken link between the Chaos Browser local database and the downloaded files (due to users moving files around)

  • Online connectivity problems (due to network restrictions or outages, antivirus programs)

Common solutions: 

  • Restart the service and reinstall Cosmos Browser. Download the latest Cosmos Browser from https://chaosgroup.com/.

  • Send us the Chaos Cosmos Browser Service logs for additional investigation. This will help us diagnose the cause of the problem.

 

Cosmos Assets

Common problems with assets: 

  • Problems in Host App view ports (due to a problematic asset or lacking support in integrations)

  • Problems in V-Ray GPU (due to a problematic asset or missing features in V-Ray GPU)

  • Problems in V-Ray Vision (due to a problematic asset or missing features in V-Ray Vision)

Common solutions: 

icon leads to an error page - “There is a problem with Chaos Cosmos”.

 

Cause 

Such problems are caused by the fact that some of the artifacts coming with Cosmos Browser, such as configuration file, database file or asset storage folder, were not installed property or were installed in directories to which clients have no read/write permissions.

 

Solution

When such problems occur, the best thing to do is update to the latest Cosmos Browser version, as it resolves most of the installation related problems. To update Cosmos Browser, follow these steps:

  1. Download the latest Cosmos Browser version on this link (requires login to your Chaos account): https://download.chaosgroup.com/?platform=47&product=62 

  2. Install it on your machine

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Connectivity Problems

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Problem 

On some occasions, starting the Chaos Cosmos Browser, leads to an error page pointing to problems with the connection to the Chaos Cosmos services.


Cause

Since Chaos Cosmos is a cloud-based service, it requires connection to the Cosmos service over the internet. There are two network problems which can interfere with that:

  • No internet connection 

  • Network firewall or missing proxy configuration

 

Solution

In the case of No internet connection - fix the network problem and connect to the internet.

In the case of firewall or missing proxy configuration, there are two things to be done (usually, by your IT admins): 

  • Configure the Cosmos Browser to work with the proxy set up in your network. You can see detailed instructions in this article.
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No access to downloads folder

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Problem

On some occasions, write rights to the asset download directory which stores assets downloaded in Cosmos are missing. In this case, download attempts result in “No access to downloads folder” error message.

 

Cause

There is an asset download folder in which all downloaded Cosmos assets are saved. The error appears when the write access to this folder is missing. By default, the asset download folder is: 

  • On Windows: C:\Users\[User Name]\Documents\Chaos Cosmos

  • On Mac: ~/Library/ChaosGroup/ChaosCosmos

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The location can be changed via UI or in the configuration file. Here is how.

 

Solution

When such problems occur, you can either: 

  • Fix the permissions to the asset download directory (your IT admin might need to assist with that). To see where Cosmos download asset directory in Cosmos Browser, go to …> Settings
    Or 

  • Change the existing asset download directory with a new one, to which you have access rights. To do so, go to …>Settings and follow these instructions.

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Oops… something went wrong

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Problem

An "Oops… something went wrong" error message appears.

 

Cause

The reason for such errors can vary.


Solution

Try and upgrade to the latest Cosmos Browser version, as described in section “There is a problem with the Chaos Cosmos error page”.
If the problem still persists, then, contact support. Make sure that you include a screenshot of the error to help diagnose the problem.

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Contacting Chaos Cosmos support

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If following the instructions in this page didn’t help and you still encounter problems with Chaos Cosmos, then you can contact our support team on this page


Please, make sure you include the cb.log as part of your ticket to help greatly in the investigation process.
To find the folder with the cb.log file, in Cosmos Browser go to …> Settings > About > Open.

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Send us info about the Cosmos Browser version and the renderer version.

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