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Problem

The most common problem with Chaos Cosmos is when the service doesn’t start due to missing files or insufficient rights to some directories created during installation. In such cases, the Cosmos Browser icon leads to an error page - “There is a problem with Chaos Cosmos”.

 

Cause 

Such problems are caused by the fact that some of the artifacts coming with Cosmos Browser, such as configuration file, database file or asset storage folder, were not installed property or were installed in directories to which clients have no read/write permissions.

 

Solution

When such problems occur, the best thing to do is update to the latest Cosmos Browser version, as it resolves most of the installation related problems. To update Cosmos Browser, follow these steps:

  1. Download the latest Cosmos Browser version on this link (requires login to your Chaos account): https://download.chaos.com/?platform=47&product=62

  2. Install it on your machine

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Problem

An "Oops… something went wrong" error message appears.

 

Cause

The reason for such errors can vary.


Solution

Try and upgrade to the latest Cosmos Browser version, as described in section “There is a problem with the Chaos Cosmos error page”.
If the problem still persists, then, contact support. Make sure that you include a screenshot of the error to help diagnose the problem.

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Unable to start Cosmos Browser service

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Problem

Sometimes Cosmos Browser service cannot start because of a problem with its database.

 

Cause

Usually downgrade of Cosmos Browser. For example, Cosmos Browser was previously installed and updated from its Update Notification, but then an older version was installed, for example with another Chaos product that also ships Cosmos.


Solution

When such problem occurs, follow these steps:

For Windows:

  • Stop the Cosmos Browser from the Start Menu shortcut.

  • Delete the DB files located at C:\user\username\AppData\Local\Chaos\Cosmos\DB

  • Start the Cosmos Browser from the Start Menu shortcut.

For Mac:

  • Delete the DB files located at /Users/username/Library/Application Support/Chaos/Cosmos/DB

  • Open Activity Monitor and search for "cbservice".

  • Force quit the process - it will automatically start again.

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Contacting Chaos Cosmos support

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If following the instructions in this page didn’t help and you still encounter problems with Chaos Cosmos, then you can contact our support team on this page.


Please, make sure you include the cb.log as part of your ticket to help greatly in the investigation process.
To find the folder with the cb.log file, in Cosmos Browser go to …> Settings > About > Open.

 

If you experience performance issues like high CPU/Memory usage, you can run the Diagnostics process (it would take about 30s) and attach the result file in your ticket.

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